Comments have been closed on this page. Please use AppMon & UEM Open Q & A forum for questions about this plugin.

  • Extend your delivery pipeline with architectural metrics captured on top of your functional/integration tests (such as Unit Test based Framework or HTTP based tests)
  • Register Test Run from Jenkins (build action)
  • Retrieve Dynatrace Test Results and push to Jenkins (post-build action)


Plugin Details


Compatible with

version 2.x: Dynatrace AppMon 6.1 and up
version 1.x: dynaTrace 5.x, dynaTrace 6


version 2.x: Dynatrace R&D
version 1.x: Wolfgang Gottesheim


Dynatrace BSD

Support Level



version 2.x: (source code releases, use Update Center to install the plugin)
version 1.x: dynatrace-dashboard_1.0.20.hpi

Source Codeversion 2.x: available at and


version 2.x:

version 1.x: Test Automation Plugin for Jenkins-v1

Report an issue

Installation / Configuration

Follow the instructions available on the Jenkins Plugin Github page. 


For detailed user guide please consult the Jenkins Plugin Github page and the Jenkins Plugin FAQ / Troubleshooting Guide

Online Perf Clinic – Eclipse and Jenkins Integration





#trackbackRdf ($trackbackUtils.getContentIdentifier($page) $page.title $trackbackUtils.getPingUrl($page))


  1. Wolfgang, is a separate license required to create this automated test dashlet?  When I create a dashboard with the 'Test Automation' dashlet, I get an error that says my license does not support analyzing 'automated tests'.  There was no mention of requiring a separate license for this during the HOT workshop in Orlando?

    1. Hi Kevin. You need a Test Center Edition License with Automation Agents in order to get access to the Test Automation Dashlet

      1. Andreas - Can you please confirm once again on the license requirements? My understanding is that 'Production Edition License' cannot support analyzing automated tests. 

        1. Correct. We are however updating this in the upcoming versions so stay tuned. 

          1. Andrea, Any update on licensing? We currently have license for AppMon and UEM? Do we need special license for this Jenkins-Dynatrace integration?

  2. We're going to implement this shortly on Jenkins.  will let you know if we run into any problems.  Thanks Wolfgang for getting this page up

  3. Hi all,


    I'm working with Teamcity and use NANT for automation. Most of the examples in the DT docs is ANT and Maven related. is there nay similar plugins and examples for Teamcity and NANT?




    1. Hi. I think you also posted a this question on the discussion forum which I just answered: Unit Test Categorization

  4. Does this plugin inject the Unit Test tagging or do we still need to add the dT agent to the Ant JVM?

    1. You still have to inject the agent yourself (Adding the agent to the Ant JVM won't do you much good IMO, you should add it to the JUnit VM)

  5. One more question, is there a minimum version of Jenkins that will support this plugin?  We have v1.508 running in our development environment right now but it seems the upload didn't seem to work.  However, I ran an install on my local 1.535 and that seemed to be ok.


    Ah, nevermind, had to reboot the Jenkins server to see it.  Working now. (smile)

  6. Hi Wolfgang,

    I am running the same build multiple times to see what kind of output I get with the Jenkins plugin and each time I am getting a different value for the # of tests passed.  All I am doing is running the same build over and over again.  Shouldn't the # passed be the same each time?

    Build #33, Passed=1
    Build #34, Passed=5
    Build #35, Passed=23
    Build #36, Passed=3

    I am passing these parameters to the top-level Maven target:

    -Dbuild.number=${label} dynaTrace:dtAutomation:3.5:setTestInformation 
    clean verify -P BuildServer

    As well, I am also putting this in our pom.xml:



    1. Hi,

      These numbers should reflect the number of passed tests per build - the plugin gets these numbers from the test automation dashlet. Could you look at one of the failed tests from #36 or #34 and see what the test automation dashlet looks like for this test? 



      1. Hi Wolfgang,

        That's the thing, there are no failed tests.  All the tests pass (it's the same build I keep running over and over with no changes).  The Test Automation dashlet does show all the tests and they are all passed.  Not sure why only a subset gets returned to the plugin.


        1. Hello,

          We are having the same issue.

          Jenkins shows our project is running a total of 158 tests with 12 tests failures and 146 successful.

          However dynatrace for each run shows diffrent numbers, sometimes 7, or 38 or 27 and these are the sames tests.

          Why these variations and why we only see a subset of our Junit tests ?




  7. HI-

    I just got this dashboard to work...great stuff!!  Just a couple of comments / questions:

    1. Is it possible to suppress the logging?  It's dumping the entire report and results, which is quite large for us.
    2. I didn't see it mentioned here, but i had to set up the dashlet properties in dynaTrace to allow for many more results.  We have much more than the default 100 tests that return in the default report.  Also, setting the timeframe for longer than the test run was helpful.  Not a problem, just an issue more people might run into.
    3. Is there any way to add this to a view?  We're looking for a landing page in Jenkins that shows all of our critical build information such as Coverage, Test Runs, and we'd like to add the dynaTrace graph too.

    Again, great work...this will be a heavily used plugin for us!  Thanks!


    1. Hi John,

      1. Sure, I will include a switch to control this behaviour
      2. Thanks for your input, I will include this in the instructions. How long are your tests running?
        In any case, this will get better with dT 5.6 when the test automation data will be available directly through the API without the detour via the dashboard report.
      3. That sounds like a great idea, I'll have to check what I have to change in the plugin to support this.

      Thanks for your feedback!


      1. Wolfgang-

        Thanks for the reply...I look forward to dT 5.6 and the improvements that will be possible due to it.  As for #2, our tests are currently running for about 2 minutes, but most are very lightweight.  We currently have 250+ tests, and we're just starting to get into 'full productivity' mode, so we're adding 15 - 20 a day at minimum.  Not a problem after I realized i had to change the dashlet properties...just took me a bit to figure that out.

        Thanks again

      2. FYI, I've just had to disable this plugin from our Jenkins installation.  Two reasons:

        1. The inability to skip logging is quite annoying, and many of our developers complain.  Minor issue.
        2. I found that our build.xml is ~467k, and the dynaTrace Results are ~456k of that.  Under heavy load, it was taking a long time to render simple JUnit reporting graphs (among other things), because it would have to read this entire file.  This effectively caused our Jenkins server to crash periodically.

        Looking at my last post, we had ~250 tests, and now we're up to 550.  So it appears that this plugin just doesn't scale with our current growth.  I would suggest a switch to turn off logging (as you suggested before), but also moving the test results out of the main build.xml file.  This is the technique that most other plugins use (TestResult, Cobertura, Jacoco, etc...).


        1. Hi John,

          Thanks again for your feedback! I have uploaded a new version yesterday that finally contains the switch to suppress logging. Do you think you could give that a try?

          On your second remark, I will definitely improve the plugin to use a separate storage file. I didn't expect this slowdown so far with my sample tests, but I understand your concern. I will post update this page once it's done



          1. Hi Wolfgang-

            Thanks again for addressing the issues.  I'm a bit wary of trying the new plugin until the 2nd issue is addressed, as we couldn't even bring Jenkins up for several hours.  This is a bit too disruptive for us, but I'd be glad to try after it is addressed.

            Thanks again!

            1. Oh, under these circumstances I can totally understand your wariness (smile) If I hear you correctly you say that the ~500k file causes Jenkins to stall? That's a behaviour I didn't experience so far...Sorry about that, I'll work on it!

              1. Wolfgang-

                Yes, it caused Jenkins to stall.   What we saw was that any request to the job's page would read in build.xml and cause a HUGE stack.  Also, Jenkins will read these files in a synchronized block, so we would have requests start piling up.  So if it took 5 - 10s (un verified times), it would do this on 10 - 20 threads (depending on how many people were accessing our Jenkins Dashboard).  This caused Jenkins to get in a state where it was simply unrecoverable.

                I actually ended up having to delete our job history (which isn't that big of a deal).

                Thanks again for your attention to the matter!


  8. Hi all,

    We are recently using this plugin for Jenkins version 1.535. After installation and machine reboot, it shows in the plugin is successfully installed. However, "dynaTrace test automation" can't be found in "Post-Build Action". (I created a dummy job by clicking New Job->Build a free-style software project)

    Is there possibly some steps I'm missing?

    Thank you!

  9. Hi,

    i use the easyTravel Ant Skript with the dynaTrace test automation. How can i pass the Build ID to the Plugin?
    Everytime i get the following message:

    Verify connection to dynaTrace Server REST interface ...
    Connection successful, getting testruninfo for this build (2014-02-20_15-11-48)
    Fetching XML Report from server 

    The buildid should be <8400f726-f64b-4fa0-8b91-f6d342f9e530> for example stored in the ${dtTestrunID} variable.

    Thank you

    1. Edit runtest.xml.  In the "DtSetTestInformation" node, modify the versionBuild attribute to ="${BUILD_ID}"

      Rick B

      1. Hi Rick,

        i already tested this setting with several builds, but everytime i get this in the dashboard:

        <testruninfo id="t2f345cfb-e448-41c9-afba-586838518463" versionmajor="2" versionminor="3" versionrevision="0" versionbuild="${BUILD_ID}" versionmilestone="Milestone 2" marker="integrationMarker"><customproperty key="committer" value="hans, peter, martin"/><customproperty key="subversion-id" value="140220160815"/><customproperty key="testset" value="alltests"/></testruninfo>
        1. You would also need the line with

          <property environment="env"/>

          at the beginning of the runtest.xml

          1. I also done that as described in the documentation above.

            Anything else i can do?


  10. Hello,

    We are trying to use this plugin 1.0.4 .

    We are using Jenkins 1.502 and we tested as well with Jenkins 1.544 on Solaris.

    We've got the maven plugin to write the test data to a dynatrace session with session name = BUILD_ID

    Started recording on ICJenkins with SessionName 2014-03-27_11-56-04

    After the build is completed, when we try to access the test results on the Jenkins web interface we see nothing, no results.

    On the Dynatrace side (5.6) we see the sessions being created with the correct information about the tests.

    At the end of the build we see the following message in the maven build log:


    No testrun found for build id 2014-03-27_11-56-04
    No test run recorded by the configured dynaTrace server - skipping data collection
    Lancement d'un nouveau build de TefouUtilitaire #166
    Finished: SUCCESS

    Anything wrong in our config ?

    1. Hi,

      You have to use the Jenkins BUILD_ID for the versionBuild parameter passed to dynaTrace in the set test information call. Are you doing that at the moment? Maybe you can share your pom.xml (either here or via mail - 



      1. Hi Wolfgang,

        We managed to get it running. Thanks.

        Actually we were making calls to startRecording and stopRecording instead of setTestInformation.

        However, I still have questions:

        1) Can we still use start/stop recording in cunjunction with setTestInformation ?

        2) How to setup the plugins if we have a multi-module maven projects ?

        3) What happens if we have multiple jenkins servers, running the plugin from different systems to DT. (Multiple agents)



        1. Hi,

          Good to hear (smile)

          @1: You can, absolutely.

          @2: I guess that depends a bit on your module structure. My first thought would be to put the dynaTrace dependency in the parent pom and define a profile for (unit/performance/integration...) tests that attaches the dynaTrace goals to the proper lifecycle phases. Could you share a bit more about your projects?

          @3: Interesting question, I haven't tried that so far. You have multiple Jenkins servers building the same project with agents connected to the same dT server? If they map into different system profiles I wouldn't see too much problems (you'd need to create multiple dashboards pointing to the respective profile)



  11. Hi Wolfgang, I have 1.0.4 installed and for some reason I have been getting NullPointerException

    Verify connection to dynaTrace Server REST interface ...
    Connection successful, getting testruninfo for this build (2014-04-15_18-39-17)
    Fetching XML Report from server
    Got testruninfoid t4ec72301-729b-4441-a60d-05a32632a4b9, continue with fetching measurements from dynaTrace Server...
    parsing XML report
    ERROR: Publisher com.dynatrace.jenkins.dashboard.TestAutomationRecorder aborted due to exception
    java.lang.NullPointerException 	at
    	at com.dynatrace.jenkins.dashboard.TestAutomationDataCollector.createReportFromBuild(
    	at com.dynatrace.jenkins.dashboard.TestAutomationRecorder.perform(
    	at hudson.tasks.BuildStepMonitor$1.perform(
    	at hudson.model.AbstractBuild$AbstractBuildExecution.perform(
    	at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(
    	at hudson.model.Build$BuildExecution.post2(
    	at hudson.model.AbstractBuild$
    	at hudson.model.Run.execute(
    	at hudson.model.ResourceController.execute(

    The only thing that has changed for us is that tests are now being categorized as "UI-Driven", so there are no more tests tagged in "Unit tests".  Does this affect it?


    1. I think I found the reason why I was getting the exception.  One thing I also did is that I had to remove the dynaTrace:dtAutomation:3.5:setTestInformation goal in order for my test to be categorized as "UI-Driven".  Prior to the mvn command, I invoke an HTTP POST to the REST services on the dynaTrace server before I invoke my mvn command:


      If the call to dynaTrace:dtAutomation:3.5:setTestInformation maven goal was made afterwards, I found it would overwrite my previous setmetadata call and I would no longer get tests tagged under UI-Driven.

      Wondering if there is a way around this?  I tried setting the <dynaTrace.category>uidriven</dynaTrace.category> within the pom.xml but that did not do anything.

    2. Hi Kevin, it shouldn't affect it, but it looks like a bug here - I'll take a look.

  12. hi,

    i am getting the following error message while executing ANT target. 


    BUILD FAILED C:\Program Files (x86)\Jenkins\jobs\Jmeter_TeamA_AddUser\workspace\build.xml:42: Problem: failed to create task or type DtSetTestInformation
    Cause: The name is undefined.
    Action: Check the spelling.
    Action: Check that any custom tasks/types have been declared.
    Action: Check that any <presetdef>/<macrodef> declarations have taken place.


    1. Hi Prabhu,

      You'll need to add theAutomation Library for dynaTrace to your Ant project to resolve dtsettestinformation

      Rick B

      1. Hi Richard,

        Sorry if the answer maybe will be obvious but... I'm having the same problem executing "runtest.xml" from easyTravel's "TravelTest" folder, from easyTravel's source code in eclipse:



        C:\XXXX\TravelTest\runtest.xml:129: Problem: failed to create task or type DtSetTestInformation

        Cause: The name is undefined.

        Action: Check the spelling.

        Action: Check that any custom tasks/types have been declared.

        Action: Check that any <presetdef>/<macrodef> declarations have taken place.


        I've already put the "com.dynatrace.diagnostics.automation.jar" library under "TravelTest\lib\dynaTrace\" folder.

        Can you please help me? Thanks!



        1. Hi Daniel,

          Those build files are not meant to be executed outside of the easyTravel application. Please use the appropriate scenarios in easyTravel: Development Team section -> Unit/Integration Testing scenario.

          Wiktor Bachnik

          1. Hi Wiktor,

            Thanks for your rapid response.

            I would like to explain you what I'm trying to achieve, so maybe you can tell me if it is possible or not with easyTravel application (smile)

            My final goal is being able to show our clients how Dynatrace can close the full development cicle (development, build, unit tests, and integration tests).

            In order to accomplish this goal, I have planned the next milestones:

            -          Import and compile easyTravel code in an eclipse project.

            -          Run an existing test file and see the results in Dynatrace.

            -          Make a change in code (e.g.: any change that increment the DB calls) and then run again the test to be able to compare, in Dynatrace, the differences between these two executions and show the client the benefit of drilling into details like this with Dynatrace.

            -          Integrate the process for building and running Ant tests with Jenkins, taking advantage of Dynatrace plugin for Jenkins.

            -          Finally, when pushing any change in code to a Git repo, automatize a build+test run task in Jenkins.

            Thanks for your time!

            1. As this has not a whole lot to do with the Jenkins plugin and I would like to keep this page focused - would you mind posting this in the Continuous Delivery Forum?


            2. I was just writing my reply when Wolfgang posted his. Let's continue the discussion in the forum.

              Wiktor Bachnik

              1. Thanks to all! I'm going to post this in the forum.


  13. hi Rick


    i have tried to options mentioned in that link.. I am able to move forward and with my ANT script i can now create a session, stop it and generate report. but i am not able to display Dynatrace metrics in Jenkins.. 

    Will the plugin mentioned in this post will work only with "Test Automation dashlet " ?

    1. Any specific error you are getting which you can share?  I have a hunch you just need to save the Test Automation dashlet in a dashboard and reference this dashboard name in the configuration of the plugin in Jenkins


      Rick B

  14. Hi All,

    I am working on Test automation, Integrating Jenkins-JMeter-Dynatrace using maven.

    I am able to connect Dynatrace dashboard successfully in 'post build action'. Had downloaded the dtAutomation jar and pasted in my local repo.

    I am getting following error after setting Goal: -Dbuild.number=${BUILD_ID} dynaTrace:dtAutomation:3.5:setTestInformation 

    Exception in thread "main" java.lang.NoSuchMethodError: org.codehaus.plexus.util.xml.pull.MXParser.<init>(Lorg/codehaus/plexus/util/xml/pull/EntityReplacementMap;)V

    Please suggest for above error and what else I need to take care in POM.xml.


    1. Hi,

      without having a look at your pom.xml it's a bit of guessing, but you have to use an empty <additionalProperties> block with the dynaTrace maven plugin. Could you maybe try that?



  15. Hi all,

    I have been working with Wolfgang on some of the challenges I have had getting the Jenkins plugin and the test Automation reports to show up properly.

    Has anyone else on this forum been able to get the reports to show up properly for Browser agent tests?  I have tried and tried, but can never get it to work.  I have been able to get JUnit tests to show up ok, but never for Browser agent tests.

    1. Hi Kevin, can you open a new forum post for this, so we can converse in detail?  Please include whether you're able to get the Browser Tests to show in Test Automation or not, besides Jenkins.


      Rick B

  16. Thanks Rick, I've created a new forum post here: Browser tests + Jenkins plug-in

  17. Hello,

    For some reason I am not able to see the test results for my performance tests, only for Unit Tests. Is that the expected behavior or I am missing something?


    Also, in dT I see way more tests than in Jenkins (dT says 250 OK tests and 21 failed vs 88 OK and 7 failed in Jenkins). I was not able to find an explanation for that so far... Need your help!




      1. Hi Luciana, Thanks for the reminder, I have updated the installation instruction on this page.

  18. Hi,


    Revisiting a question asked a bit higher up in the thread that wasn't addressed.

    Is TeamCity supported as well? I have a customer inquiring about this.


    Thanks for your help,


    1. Hi Kristof,

      I thought I already replied here (or via email?), but for future reference - TeamCity is not supported by this plugin. However, it's definitely something I'd like to cover in the future as well, but currently Bamboo is higher up in the list...


      1. Hi Wolfgang,

        Thanks for the update.


  19. Hello Wolfgang,

    We are having some problems with the jenikins plugin.

    We have upgraded all to the latest version dynatrace 6 and the latest maven plugin and the latest Jenkins plugin.

    We have plenty of MAVEN multi-module projects.

    For each module, a new build number is used. After the build is completed, the jenkinsDT plugin displays an arbitrary number of tests between 0 and the maximum number of tests.


    any hints ?



    1. Hi Nourrédine,

      I'm trying to understand how your environment looks like - if I understand it correctly you have one Jenkins project per Maven module?


      1. Wolfgang,

        No, we have one jenkins project that contains many maven modules.

        Each module contains tests, therefore, the surefire plugin is invoked many time.

        Each time with a different build number. At the end of the build, the DT jenkins plugin displays an arbitrary number of tests run. For instance, if you have 147  total, the DT plugin will display sometime 79, sometime 30 sometime 120 etc...

        We noticed by looking at the XML report that the build number is different for each module...

        Here is a dump of the example:


        [INFO] Reactor Summary:
        [INFO] ------------------------------------------------------------------------
        [INFO] propagateur ........................................... SUCCESS [3.026s]
        [INFO] propagateurShared ..................................... SUCCESS [8.853s]
        [INFO] propagateurServer ..................................... SUCCESS [32.945s]
        [INFO] propagateurWebApp ..................................... SUCCESS [27.021s]
        [INFO] propagateurEar ........................................ SUCCESS [0.884s]
        [INFO] ------------------------------------------------------------------------
        [INFO] ------------------------------------------------------------------------
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 1 minute 15 seconds
        [INFO] Finished at: Thu Oct 23 11:02:25 CEST 2014
        [INFO] Final Memory: 290M/637M
        [INFO] ------------------------------------------------------------------------
        channel stopped
        Sleeping for the configured delay of 5sec
        Verify connection to dynaTrace Server REST interface ...
        Connection successful, getting testruninfo for this build (2014-10-23_11-00-49)
        Fetching XML Report from server
        For debugging: XML report from dynaTrace Server: <?xml version="1.0" encoding="utf-8"?>
        <dashboardreport name="propagateur" version="" reportdate="2014-10-23T11:02:36.947+02:00" description="">
          <source name="propagateur" filtersummary="last 6h"></source>
            <testautomation name="Test Automation" description="" displaysource="Base">
                <testcase testname="TypeEncryptageServiceImplTest.testUpdate" violationpercent="0.0" assignees="" status="Passed" prevstatus="Passed" lastrun="2014-10-23T11:01:45.846+02:00" platform="SunOS 5.10 sun4v">
                    <testmetric violatedabove="0" violationpercent="0.0" platform="SunOS 5.10 sun4v" measure="Failed Transaction Count" high="0.0" last="0.0" unit="num" color="#13590d" agent="propagateur" metricgroup="Error Detection">
                      <testrun timestamp="2014-10-23T10:54:31.340+02:00" value="0.0" failed="false" testruninfo="t2be19842-4a1c-49be-a2ca-7c320d8efc27"></testrun>
                      <testrun timestamp="2014-10-23T10:57:45.049+02:00" value="0.0" failed="false" testruninfo="tb8f5f05d-1484-44fa-a55a-c788a8219893"></testrun>
                      <testrun timestamp="2014-10-23T11:01:45.846+02:00" value="0.0" failed="false" testruninfo="t95bfa92f-d3fd-4577-baea-fee1f3616a1c"></testrun>
                <testruninfo id="tb8f5f05d-1484-44fa-a55a-c788a8219893" versionbuild="2014-10-23_10-56-33"></testruninfo>
                <testruninfo id="ta6bc831a-4a0e-4d03-b541-bf9e22691599" versionbuild="2014-10-23_11-00-49"></testruninfo>
                <testruninfo id="t19cd3e25-3a75-4ecd-9b2c-563d6b5c64d1" versionbuild="2014-10-23_10-53-05"></testruninfo>
                <testruninfo id="t2be19842-4a1c-49be-a2ca-7c320d8efc27" versionbuild="2014-10-23_10-53-05"></testruninfo>
                <testruninfo id="t95bfa92f-d3fd-4577-baea-fee1f3616a1c" versionbuild="2014-10-23_11-00-49"></testruninfo>
                <testruninfo id="t49c5cf1c-dca5-4a7e-a761-f203abb2aa58" versionbuild="2014-10-23_10-56-33"></testruninfo>
        Got testruninfoid ta6bc831a-4a0e-4d03-b541-bf9e22691599, continue with fetching measurements from dynaTrace Server...
        parsing XML report
        got results for 17 test cases
        Report built!
        TestCase Summary: {Failed=0, Volatile=0, Degraded=0, Improved=0, Passed=17}, fail build on results: true
        Build status is: SUCCESS
        Finished: SUCCESS
        1. OOOPS.

          Sorry, the report is a bit long to post...feel free to cut off.


        2. The DT jenkins report says:


          Build #PassedImprovedVolatileDegradedFailed


          The dump I posted concerns build #33 and shows only 17 tests passed.

          On the DT client, we see all pure paths and all data correct.

          Jenkins displays the correct number of tests (127):

          1. Hi,

            did you find a solution for this issue? I'm facing the same. The Dynatrace client is showing > 2600 tests, but the Jenkins dashboard shows randomly ca. 800 or only 30, depending on which ID it accesses it on the server.

            I tried setting the dtTestrunId manually as Maven property like {{<dtTestrunID>${BUILD_TAG}</dtTestrunID>}}, but then the Jenkins dashboard completely failed to get the XML report and the version in Dynatrace was "-.-.-.1 (autogenerated)".

            would be great if we could solve this issue, otherwise the Jenkins integration is not really helpful...




  20. Hi,

    wich is the minimal version of jenkins supported ? In version 1.509.4, plugin is not diplayed by default, is there a risk to install it ?



    1. Hi,

      As far as I know the interfaces used haven't changed since 1.509, although I have to admit I haven't tried it myself. But the plugin itself is built against a certain version (1.535), so I'm not sure if you can actually install it on an older build. Probably the easiest way is to try...


      1. Hi,

        i have build_id with me but how to send it to dynatrace to retrive the test information to show in Jenkins.Please help me how to do this.




  21. I'm working with the new 2.x version of the plugin. I'm using a NAnt script for the test. It is able to start the test, talk to the DT server and start/stop recording. After I run the test, I see the data in the DT client. The problem comes when Jenkins makes a rest call to pull back the test information. I noticed that when the test runs it has one id, but when Jenkins makes the call it has a second id. That means it pulls back no data. In the plugin doc, it talks about passing the id to the agent, but only for java. Is there a way I should be passing the the id to the .Net agent config?


    1. The test id must be passed to the .net agent through the environment variable DT_TESTRUN_ID (see also .NET Agent Configuration)
      Feel free to do a push request to update the documentation to include a snipplet for NAnt once you have it running. I'm sure it will be useful to others.

      1. I got the environment variable to work. I used the 'Environment Injector Plugin' in Jenkins and injected the DT_TESTRUN_ID variable between the Register Test Run and the Execute Build steps.

        1. thanks for sharing - I just updated the documentation with this information:

  22. I'm using the 2.x version of the plugin and I'm seeing a NumberFormatException when the plugin parses the XML. One of the values is 'INF', instead of a number. Has anyone seen this before?

    See the log below:

    Total time: 9.5 seconds.

    Dynatrace AppMon Plugin - build tear down...
    Storing session via Dynatrace Server REST interface...
    Dynatrace session Jenkins_Jenkins_build_10 [2016-06-07 09:46:34] has been stored
    Sleeping for the configured delay of 20 seconds before retrieving test run data from Dynatrace Server...
    Connecting to Dynatrace Server REST interface... (ID=19c1481a-4c9e-4d45-96a9-c54b2604eebf)
    HTTP status code from Dynatrace Server: 200
    DEBUG: XML response from Dynatrace Server REST interface:
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?><testRun category="performance" versionBuild="10" versionMajor="1" versionMilestone="4" versionMinor="2" versionRevision="3" startTime="1465307205375" id="19c1481a-4c9e-4d45-96a9-c54b2604eebf" numPassed="0" numFailed="0" numVolatile="0" numImproved="0" numDegraded="1" numInvalidated="0" sessionId="Jenkins/20160607094634_0.t0.session" session="Jenkins_Jenkins_build_10 [2016-06-07 09:46:34]" marker="test"><testResult name="UnitTestCases.count(1000000)" status="degraded" exectime="1465307205375" package="TestCases"><measure name="PurePath Duration" metricGroup="PurePaths" value="64.776123046875" unit="ms" expectedMin="0.0" expectedMax="0.0" numFailingOrInvalidatedRuns="0" numValidRuns="5" numImprovedRuns="0" numDegradedRuns="7" violationPercentage="INF"/><measure name="Failed Transaction Count" metricGroup="Error Detection" value="0.0" unit="num" expectedMin="0.0" expectedMax="0.0" numFailingOrInvalidatedRuns="0" numValidRuns="12" numImprovedRuns="0" numDegradedRuns="0" violationPercentage="0.0"/></testResult><additionalMetaData JENKINS_JOB="job/Dynatrace%20Test%204/10/"/></testRun>
    Parsing XML response...
    Fetching data from Dynatrace Server REST interface failed
    java.lang.NumberFormatException: For input string: "INF"
    Finished: SUCCESS

      1. Thank you. That worked.

  23. the github link to releases takes you to a tar and zip download, but it does not contain the HPI file to upload. Can someone fix it please.




    1. Hi Mike,

      Please use Jenkins Update Center to install the plugin. There's no more need for manual installation.



      1. Proxy is blocking within our organization. We receive 407 http error code when trying to install plugin via Update Center. What are the alternatives?

        1. In that case you can simply clone the repository and build the plugin using Maven. Just issue the command mvn package and after it's built you'll be able to find the .hpi file in the target folder.

  24. Hi!  I filed an issue here per the header in the github repo, but didn't get a response.  I'd like to do the refactoring work necessary to get the plugin manageable by Jenkins Pipeline script.  Where should I branch from? 


    Assuming this is a question for Wiktor Bachnik or Krzysztof Necel

  25. I am using test centre edition and got some issue in terms of fetching record from dynatrace, it used to work for sometime and now I started getting below error of retry in jenkins console. I am able to see Testin appmon, and my header is also injected correctly. Please let me know how to debug and find my jenkins is not getting data from dynatrace appMon and display in jenkins ui. I am using jenkins 1.651.3 and my dynatrace plugin version is latest for jenkins. 



    Dyna log 

    2017-03-10 12:32:30 INFO [RestRequestStatistics] Rest Statistics - number of requests: 0, total time: 0ms

    2017-03-10 12:43:26 WARNING [EmailUtils] Could not find email address of user: 'admin'.

    2017-03-10 12:48:33 WARNING [XmlRestManagementService] No tests were executed within testRun with id='261e336f-c7e2-4145-9d97-b8df563fac43'

    2017-03-10 12:48:43 WARNING [XmlRestManagementService] No tests were executed within testRun with id='261e336f-c7e2-4145-9d97-b8df563fac43'

    2017-03-10 12:48:53 WARNING [XmlRestManagementService] No tests were executed within testRun with id='261e336f-c7e2-4145-9d97-b8df563fac43'

    2017-03-10 12:49:03 WARNING [XmlRestManagementService] No tests were executed within testRun with id='261e336f-c7e2-4145-9d97-b8df563fac43'

    jenkins consle log

    Dynatrace AppMon Plugin - build tear down...

    Sleeping for the configured delay of 10 seconds before retrieving test run data from Dynatrace Server...

    Connecting to Dynatrace Server REST interface... (ID=261e336f-c7e2-4145-9d97-b8df563fac43)

    Sleeping for the configured delay of 10 seconds before retrieving test run data from Dynatrace Server... re-try 1 out of 3

    Connecting to Dynatrace Server REST interface... (ID=261e336f-c7e2-4145-9d97-b8df563fac43)

    Sleeping for the configured delay of 10 seconds before retrieving test run data from Dynatrace Server... re-try 2 out of 3

    Connecting to Dynatrace Server REST interface... (ID=261e336f-c7e2-4145-9d97-b8df563fac43)

    Sleeping for the configured delay of 10 seconds before retrieving test run data from Dynatrace Server... re-try 3 out of 3

    Connecting to Dynatrace Server REST interface... (ID=261e336f-c7e2-4145-9d97-b8df563fac43)

    Report summary: {Failed=0, Degraded=0, Volatile=0, Improved=0, Passed=0}.

    only thin changed is, when it was working it used to connect and fetch test data in single retry, but now it is keep going for 3 times. 

    Working test data upload 

    Dynatrace AppMon Plugin - build tear down...
    Sleeping for the configured delay of 10 seconds before retrieving test run data from Dynatrace Server...
    Connecting to Dynatrace Server REST interface... (ID=ecf6ed03-c975-4db6-a995-2c4b80b1ecc1)
    Report summary: {Failed=0, Degraded=0, Volatile=4, Improved=0, Passed=4}.